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KRYO-FLEX Low Temperature
Device (for D8/PLATFORM)
User’s Manual
Purpose
These instructions cover use of the KRYO-FLEX Low
Temperature Device software, which controls the low
temperature device and dewar that cool the sample for
various applications.
NOTE: This procedure assumes that the KRYO-FLEX
software (which may be a standalone program or part of the
PROTEUM program suite) has been installed on your
system.

Responsibilities
All procedures are to be performed by general users, site
administrators, and trained Bruker AXS personnel.

Disclaimer
All configurations and specifications are subject to change
without notice.

1

Features

Before using the program, you will want to be
familiar with the main window (Figure 1) and
its features. This section explains those
features.
Temperature Units
The Temperature Units subwindow allows you
to select the temperature units that you wish
to use. Two unit options are available: Kelvins
(K) and Celcius (C) When setting the units,
click on the circle next to your desired option
(K or C).

Referenced Literature
• none

Figure 1. KRYO-FLEX Control-Running window
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Note that the change will immediately affect
all temperatures in the main window.
Current Temperature
The current temperature of the sample
displays both as a thermometer (that
indicates the maximum and minimum range
of the temperature) and as text below the
thermometer, with the temperature displaying
in those units you have chosen.
A flashing thermometer indicates an error
related to temperature. A message in the text
subwindow by the Status lamps may explain
the error.
Set Temperature
The Set Temperature subwindow is where
you set a target temperature, which is the
temperature you will want the system to cool
to, stabilize at, and maintain throughout the
experiment once you start KRYO-FLEX. Here
you simply enter a target temperature in the
provided field or scroll to a desired
temperature using the arrows beside the field.
A range of 90° to 300°K or -183.5° to 26.5°C
is allowed by the system. You will be warned
if you enter values outside this range or if you
accidentally enter a nonnumeric value.
Temperature vs. Time
The current temperature also gets recorded in
the Temperature vs. Time graph (center
subwindow) to show you what KRYO-FLEX is
doing over a period of time.
During the cooling operation, a dark line
forms (see Figure 1 example near 300° mark)
to mark the exact temperatures at different
points along the timeline. Two light lines form
(see Figure 1 example near 100° mark—lines
are so close, they appear as one) to indicate
the acceptable range of temperatures for the
current target temperature (the range being
target temperature 0.1). These lines appear
on the graph so that you can visually verify
the temperature stability. During non-cooling,
temperatures will rise to room temperature,
and these will record in the graph for the
extent of that period.

has stabilized at the target temperature. This
auto-zoom feature allows you to readily see
the current temperature in relation to previous
temperatures for stability monitoring (that is,
to see the temperature’s likely rate of
change).
You may also manually zoom in on or out of
the graph and see temperatures over a period
of your choosing. To zoom in on a specific
period, left-click drag across the temperature
points you wish to magnify. Upon releasing
the mouse, your selected area will enlarge
and fill the subwindow. This feature is
recursive, meaning that you can select a time
range within a time range (further zoom) to
narrow the specific range shown. When you
want to return to the entire time range
recorded in the chart, right-click.
N2 Flow
The N2 (nitrogen) flow status displays as a
scale in the N2 Flow subwindow, and as text
below the indicator.
The KRYO-FLEX control is default set with a
nitrogen flow rate of 5 liters per minute.
However, when first cooling, the KRYO-FLEX
control may switch to a Turbo Mode that uses
a higher flow rate of 7.5 liters per minute to
speed the cooling process.
Status Lamps
In the Status subwindow, two status lamps
indicate KRYO-FLEX operation.
The KF lamp indicates specific KRYO-FLEX
control status as follows:

•

A lamp not lit indicates that the control is
not actively cooling.

•

A yellow lamp indicates that the control is
cooling but the temperature has not
stabilized. A message appears next to the
lamp that explains the status and states
the target temperature.

•

A green lamp indicates that the control
has stabilized at the target temperature. A
message appears next to the lamp that
explains the status. Stabilization occurs
when 90% of the observed temperatures
fall within the "acceptable range" (0.1)
over a period of 3 minutes.

•

A red lamp indicates that a serious error
has occurred and that the control is no
longer cooling due to that error. A
message appears next to the lamp that
explains the status.

Automatic and manual zoom modes allow
you to view the graph to monitor operation or
check particular information.
The graph automatically zooms out
(displaying the entire range of temperatures—
cooling and non-cooling) when the
temperature is not stable and zooms in
(displaying the temperature range acceptable
for stable operation) when the temperature
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The BIS lamp shows if the KRYO-FLEX
control is connected to the Bruker Instrument
Service. If the lamp lights green, the control is
connected. If the lamp is not lit, the control is
not connected.
Liquid Nitrogen Dewar
The Liquid Nitrogen Dewar subwindow shows
you the level of liquid nitrogen in the dewar
and provides two options for refilling the
dewar. A dewar graphic shows three states at
which the nitrogen supply may exist in the
dewar: full, within operational range, and
empty. These states are controlled by two
level sensors in the dewar, which detect the
amount of liquid nitrogen in the dewar. The
first (full-level sensor) senses when the dewar
is full. The second (low-level sensor) senses
when the dewar is almost empty. Figure 2
shows the different stages.
Full

Within Range

Empty

Full dewar,
indicated by
fully green
graphic

Partially
depleted
dewar,
indicated by
partially green
graphic

Empty dewar,
indicated by
white graphic
with low level
in red to stress
refill urgency

Figure 2. Stages of liquid nitrogen level in dewar

A flashing dewar indicates an error related to
liquid nitrogen. A message in the text
subwindow by the Status lamps may explain
the error.
To ensure smooth operation and prevent
damage to your sample (in the event that the
liquid nitrogen would run out), you can have
the KRYO-FLEX system automatically refill
the dewar when the liquid nitrogen level
reaches the low-level sensor (if a refill tank
with sufficient liquid nitrogen is connected to
the dewar). To enable the refill feature, simply
check the Auto Dewar Refill box in the Liquid
Nitrogen Dewar subwindow.
When the automatic refill option is enabled,
you can also force the refill to start and stop
by pressing the Force Refill to Start button
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(button text changes between Start and Stop
when toggled).
Start/Stop KRYO-FLEX
You press the Start KRYO-FLEX button
(bottom right corner of the main window)
when you are ready to cool a sample. (Button
text changes to Stop KRYO-FLEX.) When
you are done collecting data for a sample and
no longer need to cool it, press the Stop
KRYO-FLEX button to stop flow of liquid
nitrogen. Button text will change back to Start
KRYO-FLEX.

2

Startup

With the KRYO-FLEX system set up as
explained in the KRYO-FLEX Installation
Manual, you should be able to run the KRYOFLEX control software to control the hardware
instead of having to manually control the
hardware.
1. Double click the KRYO-FLEX icon
(snowflake in standalone program,
thermometer in the PROTEUM program)
to start the KRYO-FLEX program. The
KRYO-FLEX Control-Running window
appears (recall Figure 1).

3

Operation

3.1

Basic Use

To prepare the system for basic use:
1. In the Temperature Units subwindow,
select the temperature unit (K=Kelvin or
C=Celsius) that you wish the KRYO-FLEX
control to use. Note that the change will
affect all temperatures in the main
window.
2. Set (or change) the target temperature by
entering a new value in the Target
Temperature field of the Set Temperature
subwindow.
3. Press the Start KRYO-FLEX button to
start cooling.
NOTE: Press the Stop KRYO-FLEX button
when you want to stop cooling.

3

3.2

Create a Log File

1. Click File > Log File Settings to have the
KRYO-FLEX control create a log file of
the recorded temperatures (Figure 3).
Figure 6. Log File Settings input panel

4. Check the Log File Active box to tell the
KRYO-FLEX control to activate the log
file and record the temperatures into the
log file.
5. Click File > Close (or the [x] box) to close
the panel and return to the Control
window.
If, at some point, you wish to view or edit
the logfile, simply return to this panel and
press the Open Logfile button. The
notepad appears and displays your
logfile. Or if you find that you are finished
with the logfile at some point, return to
this window and press the Clear Log File
button to delete the file.

Figure 3. KRYO-FLEX Control-Running window

The Log File Settings input panel appears
(Figure 4).

3.3
Figure 4. Log File Settings panel

2. Click on the browse button (…) to select a
logfile.
A standard Windows browse window
appears to let you open a previous logfile
or create a new one (Figure 5).

Connect to BIS

Connected to the Bruker Instrument Service
(BIS), the KRYO-FLEX control can
communicate the current temperature to BIS
and other programs (such as PROTEUM) that
also communicate with the Bruker Instrument
Service. This connection lets the programs
record the temperature to which a crystal was
cooled each time a frame from that crystal is
collected.
To connect to BIS:
1. Click on BIS > Connect to BIS.
The BIS Socket Connection window
appears (Figure 7) to request a host
name. A host name is the network name
or the IP address of the computer to
which the Bruker Instrument Service is
connected.

Figure 5. Browse window

3. Highlight a current logfile or enter a new
name in the File name field. Then
click Open.
The Log File Settings panel now shows
your selected (or new) filename
(Figure 6).

4

Usually, the KRYO-FLEX control will be
run on the same computer on which BIS
is running because BIS controls the
frame-collecting hardware and the KRYOFLEX control runs the KRYO-FLEX lowtemperature device. The KRYO-FLEX
control assumes this arrangement and, by
default, sets the host to an IP address
that is universally accepted as a local
connection. You may, however, enter any
network name or IP Address that
you wish.
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Figure 7. BIS Socket Connection window

2. At the Host field, accept the default IP
address, enter the IP address for the
Bruker Instrument Service, or enter the
host name you desire.
If you need to set the KRYO-FLEX control
back to the default IP Address, click the
Set To Local button.
3. Click the Connect to BIS button.
If you have entered a valid host name,
the KRYO-FLEX control will connect to
BIS and you can close the BIS Socket
Connection window.
To show that the KRYO-FLEX control is
connected to BIS, the BIS lamp in the
lower left corner of the KRYO-FLEX
Control-Running window turns green.

3.4

Obtain Information from
System Monitor

While the main window displays commonly
needed information, the control stores more
information in the system monitor (should you
need to access those details).
1. Click on Advanced Options > System
Monitor (Figure 8).

Figure 9. System Monitor window

3.5

Use of Zoom Fine Tuning

There are times when you may wish for finer
control of the scale of zoom that the KRYOFLEX control uses when the temperature has
stabilized. Conversely, you may wish to zoom
in even when the temperature is not
stabilized, or you may wish to zoom out when
it is stabilized. Do so as follows:
1. Click on Advanced Options > Zoom Fine
Tuning.
The Temperature vs. Time graph shrinks
slightly, and the Zoom Fine Tuning tools
show up in the new space created
(Figure 10).

Figure 8. Advanced Options menu
Figure 10. Zoom Fine Tuning tools appear under graph

The System Monitor window appears,
giving you specific details for both the
Evaporator and the Nozzle heaters. It
also gives you information on the dewar,
the nitrogen flow, and the date and time
(Figure 9).
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2. Check (or uncheck) the Zoom
Temperature Scale box of the new tools
to turn on (or off) the zoom.
When the Zoom Temperature Scale box
is checked, the Temperature vs. Time
graph will be zoomed in on the target
temperature according to the scale
settings.
5

3. Enter a scale value in the Zoom of
temperature scale in degrees field
(Figure 11) or adjust the slider bar below
the heading Zoom Temperature Scale.

Figure 11. Zoom of temperature scale in degrees

To deactivate the Zoom Fine Tuning tools,
click Advanced Options > Zoom Fine Tuning
again to uncheck it.

3.6

Set Temperature Offset

The KRYO-FLEX control assumes that the
temperature of the nitrogen stream
(dispensed and monitored slightly above the
sample) is the temperature of the crystal. This
assumption may or may not be accurate.
Sometimes the nitrogen stream can warm up
between the nozzle and the crystal, if the
nozzle is far away from the crystal. If you
know how much the nitrogen stream warms
(by taking an infrared reading at the crystal
and calculating the difference between it and
the target temperature), you can enter this
value to set the temperature offset, as
follows:

3.7

Temperature Ramping

Normally KRYO-FLEX cools down rapidly and
may overshoot your target temperature. This
rapid change is suitable for most applications,
but could damage a crystal. If your application
requires a more controlled temperature
reduction, you may want to use temperature
ramping. This feature works with a start
temperature, a scale temperature (amount by
which to slowly reduce), and an end
temperature. When this feature is set, the
KRYO-FLEX control will cool down to the start
temperature and stabilize. Then it will cool
down in incremental stages by the scale that
you set, briefly stabilizing at each stage, until
it finally reaches the end temperature that you
set. Thus, if you set a start temperature of
200°K, a scale of 10°K, and an end
temperature of 100°K, the control will cool to
200°K, then cool down 10°K at a time in
stages until it reaches 100°K.
To set temperature ramping:
1. Click Advanced Options > Temperature
Ramping to activate the temperature
ramping.
Temperature ramping controls will appear
in the Set Temperature field (Figure 13).

1. Click the Advanced Options >
Temperature Offset Setting. The
Temperature Offset input panel
appears (Figure 12).
Figure 13. Temperature ramping controls

Figure 12. Temperature Offset panel

2. Check the Use an offset of: box to tell
KRYO-FLEX to start using an offset
value.
3. Enter the offset value (difference between
infrared reading and target temperature)
in the field to the right of the box.
4. Close the panel [x] and KRYO-FLEX will
begin using the offset.
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2. Enter a start temperature in the Target
Temperature field, as you normally would.
3. Click on the Not Ramping button to enter
settings and start ramping. (Click it later
to stop ramping.)
The Ramping Settings input panel
appears (Figure 14).
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Figure 14. Ramping Settings panel

4. Enter in the Scale field the amount by
which you will want the temperature to
incrementally fall.
5. Enter an end temperature value in the
Final Temp field.
6. Click the Use these settings and start
ramping button to activate the KRYOFLEX control to use your settings.
The Ramping Settings panel will close
and the KRYO-FLEX control will start
ramping.

3.8

Wipe All Data From Graph

The Temperature vs. Time graph normally
holds all data since the software was started.
If you run the software for prolonged periods,
the graph can consume a large amount of
system memory, which may make the
software behave abnormally. To free this
memory, you may want to periodically clear
data from the graph.
To clear data from the graph, click Advanced
Options > Wipe All Data From Graph. The
data will then be cleared.
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